Workflow Suspended at Email

My SharePoint 2013 workflow keeps suspending itself at the point it’s supposed to send an email. The email details have been specified in Central Admin but it’s still not working. When the workflow is supposed to send an email out (internally) it suspends with an error. Here is the information that is given about the suspension.

RequestorId: 951f4793-1f5b-7054-0000-000000000000.

Details: An unhandled exception occurred during the execution of the workflow instance.

Exception details: System.ApplicationException: HTTP 500 {“Transfer-Encoding”:[“chunked”],
“X-SharePointHealthScore”:[“0″],”SPClientServiceRequestDuration”:[“73”],
“SPRequestGuid”:[“951f4793-1f5b-7054-ab33-e189b0ee0f23”],
“request-id”:[“951f4793-1f5b-7054-ab33-e189b0ee0f23”],
“X-FRAME-OPTIONS”:[“SAMEORIGIN”],
“MicrosoftSharePointTeamServices”:[“15.0.0.4569”],
“X-Content-Type-Options”:[“nosniff”],
“X-MS-InvokeApp”:[“1; RequireReadOnly”],
“Cache-Control”:[“max-age=0, private”],
“Date”:[“Mon, 19 Jan 2015 14:08:56 GMT”],
“Server”:[“Microsoft-IIS/8.5”],
“X-AspNet-Version”:[“4.0.30319”],
“X-Powered-By”:[“ASP.NET”]}
at Microsoft.Activities.Hosting.Runtime.Subroutine.SubroutineChild.Execute(CodeActivityContext context)
at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance,
ActivityExecutor executor,
BookmarkManager
bookmarkManager)
at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(
ActivityExecutor executor,
BookmarkManager bookmarkManager,
Location resultLocation)

Can anyone tell me what could be causing this? I’m not 100% on what this error even means.

=================

  

 

A few things you could check: – Are you running this wf as system account or normal user who is added to site/list/library? – If the user is part of a SP group, does that group membership set as everyone?
– Manu
Jan 19 ’15 at 15:49

  

 

Also please check if Require Documents to be Checked out is selected, if it is Yes change it to No and try the workflow again. Also try to uncheck the option “Automatically update the workflow status to the current stage name” in the SPD workflow properties
– Manu
Jan 19 ’15 at 15:57

=================

2 Answers
2

=================

How do you have the “To” field configured? Is it a lookup? I’m not 100% on that specific error but it’s possible the system can’t find who to send the email to.

A permissions review may resolve this issue.

For our case, we had the following architecture:

Securable object Description Unique/inherited permissions
——————– ———————— —————————-
SiteA Group home page Unique
SiteA/SubsiteA Sensitive group Inherited
SiteA/SubsiteA/ListA Sensitive data Inherited

List “SubsiteA/ListA” represented the list associated with our failing workflow.

The root site, “SiteA”, had the following permissions, with subsite “SubsiteA” inheriting permissions:

Name Type Permission Levels Members
—————– —————— —————– —————
SiteA Owners SharePoint Group Full Control “ADomain\ADistributionList”
SiteA All People SharePoint Group Contribute Empty
SiteA Members SharePoint Group Edit Empty
SiteA Visitors SharePoint Group Read “NT AUTHORITY\authenticated users”

Active Directory distribution list “ADDistributionList1” contained an Active Directory named account of the user editing the list (for example, “ADomain\AUser”).

After adding “ADomain\AUser” to group “SiteA Owners”, all workflows began working.

This indicates a permissions issue may trigger this issue. One thought: I believe SharePoint may require access to the hidden list “Workflow History”, accessible via SharePoint Designer > All Files > Lists (hat tip). Other issues may exist.