Infopath Href problem

i have created a link in my main page in Sharepoint 2007, I’m trying to create a link reference to open the form that i publush in my form library. But the problem is that whenever i click the link, it direct me to the library form page instead of opening the form. Anyone can help me out?

href=”http://myServer/test/InfoPath/Forms/ALLItems.aspx?XsnLocation=http://myserver/test/infopath/form.xsn”

=================

  

 

maybe add “?OpenInBrowser=true” at the end ? or something similar
– Nico
Jan 20 ’15 at 15:31

  

 

In the library where you have published the form, can you access it using the New menu item? That way you can get the url of the form.
– Manu
Jan 20 ’15 at 15:37

  

 

@Manu No, whenever i click new document it ask me to search the xml. it’s that the reason?
– Andy
Jan 20 ’15 at 15:40

  

 

@Nico I’ve tried that too, and it doesn’t work
– Andy
Jan 20 ’15 at 15:40

=================

1 Answer
1

=================

You can create the HyperLink as follows

Publish Form

Give this a try

Publish Form

msdn.microsoft.com/en-us/library/ie/ms772417.aspx

I tried this exactly like the href that you gave me , but it still redirect me to the form library and not open it

href=”http://myServer/testpage/infoPath/Forms/AllItems.aspx?XsnLocation=http://myServer/testpage/infopath/form.xsn&SaveLocation=http://myServer/testpage/infopath&Source=http://myServer/testpage/infopath”

  

 

I did that and it force me to save the form in my library but what i want is to open in the browser.
– Andy
Jan 20 ’15 at 15:42

  

 

Is your form browser enabled? Is it published as a content type?
– Manu
Jan 20 ’15 at 15:43

  

 

no, but it does open when i am in the library form, it didn’t ask me to save the form.
– Andy
Jan 20 ’15 at 16:14

  

 

if the form isn’t browser enabled then Amal’s solution should open it in client, provided you have InfoPath client or filler installed
– Manu
Jan 20 ’15 at 16:17

  

 

@user3281912 check the update. I just typed the URL, so you might need to adjust based on your setup.
– Amal Hashim
Jan 20 ’15 at 16:18